#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ":smile_([0-9]{0,2}):"
Local $sString = ":smile_1:" & @CRLF & _
":smile_2:" & @CRLF & _
":smile_3:" & @CRLF & _
":smile_4:" & @CRLF & _
":smile_5:" & @CRLF & _
":smile_6:" & @CRLF & _
":smile_7:" & @CRLF & _
":smile_8:" & @CRLF & _
":smile_9:" & @CRLF & _
":smile_10:" & @CRLF & _
":smile_11:" & @CRLF & _
":smile_12:" & @CRLF & _
":smile_100:"
Local $sSubst = "<img src="/$1.png">"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)