import Foundation
let pattern = #":smile_([0-9]{0,2}):"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
:smile_1:
:smile_2:
:smile_3:
:smile_4:
:smile_5:
:smile_6:
:smile_7:
:smile_8:
:smile_9:
:smile_10:
:smile_11:
:smile_12:
:smile_100:
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<img src="/$1.png">"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)