import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":smile_([0-9]{0,2}):";
final String string = ":smile_1:\n"
+ ":smile_2:\n"
+ ":smile_3:\n"
+ ":smile_4:\n"
+ ":smile_5:\n"
+ ":smile_6:\n"
+ ":smile_7:\n"
+ ":smile_8:\n"
+ ":smile_9:\n"
+ ":smile_10:\n"
+ ":smile_11:\n"
+ ":smile_12:\n"
+ ":smile_100:";
final String subst = "<img src=\"/$1.png\">";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}