const regex = /:smile_([0-9]{0,2}):/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':smile_([0-9]{0,2}):', 'g')
const str = `:smile_1:
:smile_2:
:smile_3:
:smile_4:
:smile_5:
:smile_6:
:smile_7:
:smile_8:
:smile_9:
:smile_10:
:smile_11:
:smile_12:
:smile_100:`;
const subst = `<img src="/$1.png">`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);