using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Mode:\S*)\s*(Frequency:\S*\s*GHz)\s*(Access Point:\s*\S*)";
string input = @"Mode:Managed Frequency:2.462 GHz Access Point: 00:00:00:00:00:00";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}