re = /(Mode:\S*)\s*(Frequency:\S*\s*GHz)\s*(Access Point:\s*\S*)/
str = 'Mode:Managed Frequency:2.462 GHz Access Point: 00:00:00:00:00:00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end