// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(Mode:\S*)\s*(Frequency:\S*\s*GHz)\s*(Access Point:\s*\S*)").unwrap();
let string = "Mode:Managed Frequency:2.462 GHz Access Point: 00:00:00:00:00:00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}