package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(Mode:\S*)\s*(Frequency:\S*\s*GHz)\s*(Access Point:\s*\S*)`)
var str = `Mode:Managed Frequency:2.462 GHz Access Point: 00:00:00:00:00:00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}