import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Mode:\\S*)\\s*(Frequency:\\S*\\s*GHz)\\s*(Access Point:\\s*\\S*)";
final String string = "Mode:Managed Frequency:2.462 GHz Access Point: 00:00:00:00:00:00";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}