$re = '/(Mode:\S*)\s*(Frequency:\S*\s*GHz)\s*(Access Point:\s*\S*)/';
$str = 'Mode:Managed Frequency:2.462 GHz Access Point: 00:00:00:00:00:00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);