#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)INIT\s*--\s*(?<label>\w+)\n" & @CRLF & _
"\s+UP:\s*(?<up>\d+)\n" & @CRLF & _
"(?<uplines>(?:\s+(?!\s*DOWN).*\n)*)" & @CRLF & _
"\s+DOWN:\s*(?<down>\d+)\n" & @CRLF & _
"(?<downlines>(?:\s+(?!\s*INIT).*\n)*)"
Local $sString = " INIT -- FOO" & @CRLF & _
" UP: 1" & @CRLF & _
" UpLine #1" & @CRLF & _
" DOWN: 2" & @CRLF & _
" DownLine #1" & @CRLF & _
" DownLine #2" & @CRLF & _
"" & @CRLF & _
" INIT -- BAR" & @CRLF & _
" UP: 0" & @CRLF & _
" DOWN: 2" & @CRLF & _
" DownLine #1" & @CRLF & _
" DownLine #2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")