// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)INIT\s*--\s*(?<label>\w+)\n
\s+UP:\s*(?<up>\d+)\n
(?<uplines>(?:\s+(?!\s*DOWN).*\n)*)
\s+DOWN:\s*(?<down>\d+)\n
(?<downlines>(?:\s+(?!\s*INIT).*\n)*)").unwrap();
let string = " INIT -- FOO
UP: 1
UpLine #1
DOWN: 2
DownLine #1
DownLine #2
INIT -- BAR
UP: 0
DOWN: 2
DownLine #1
DownLine #2
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}