import Foundation
let pattern = #"""
INIT\s*--\s*(?<label>\w+)\n
\s+UP:\s*(?<up>\d+)\n
(?<uplines>(?:\s+(?!\s*DOWN).*\n)*)
\s+DOWN:\s*(?<down>\d+)\n
(?<downlines>(?:\s+(?!\s*INIT).*\n)*)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = ##"""
INIT -- FOO
UP: 1
UpLine #1
DOWN: 2
DownLine #1
DownLine #2
INIT -- BAR
UP: 0
DOWN: 2
DownLine #1
DownLine #2
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)