package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`INIT\s*--\s*(?<label>\w+)\n
\s+UP:\s*(?<up>\d+)\n
(?<uplines>(?:\s+(?!\s*DOWN).*\n)*)
\s+DOWN:\s*(?<down>\d+)\n
(?<downlines>(?:\s+(?!\s*INIT).*\n)*)`)
var str = ` INIT -- FOO
UP: 1
UpLine #1
DOWN: 2
DownLine #1
DownLine #2
INIT -- BAR
UP: 0
DOWN: 2
DownLine #1
DownLine #2
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}