const regex = /INIT\s*--\s*(?<label>\w+)\n
\s+UP:\s*(?<up>\d+)\n
(?<uplines>(?:\s+(?!\s*DOWN).*\n)*)
\s+DOWN:\s*(?<down>\d+)\n
(?<downlines>(?:\s+(?!\s*INIT).*\n)*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('INIT\\s*--\\s*(?<label>\\w+)\\n
\\s+UP:\\s*(?<up>\\d+)\\n
(?<uplines>(?:\\s+(?!\\s*DOWN).*\\n)*)
\\s+DOWN:\\s*(?<down>\\d+)\\n
(?<downlines>(?:\\s+(?!\\s*INIT).*\\n)*)', 'g')
const str = ` INIT -- FOO
UP: 1
UpLine #1
DOWN: 2
DownLine #1
DownLine #2
INIT -- BAR
UP: 0
DOWN: 2
DownLine #1
DownLine #2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}