#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*(?=(?:color|background-color|background-image)\:.*?;).*"
Local $sString = "header p {" & @CRLF & _
"color:#f2f3ed;" & @CRLF & _
"background-color:#353535;" & @CRLF & _
"background-image: url(../images/dots.png);" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"header p {" & @CRLF & _
"background-image: url(../images/dots.png);" & @CRLF & _
"background-color:#353535;" & @CRLF & _
"color:#f2f3ed;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")