using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*(?=(?:color|background-color|background-image)\:.*?;).*";
string input = @"header p {
color:#f2f3ed;
background-color:#353535;
background-image: url(../images/dots.png);
}
header p {
background-image: url(../images/dots.png);
background-color:#353535;
color:#f2f3ed;
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}