import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*(?=(?:color|background-color|background-image)\\:.*?;).*";
final String string = "header p {\n"
+ "color:#f2f3ed;\n"
+ "background-color:#353535;\n"
+ "background-image: url(../images/dots.png);\n"
+ "}\n\n"
+ "header p {\n"
+ "background-image: url(../images/dots.png);\n"
+ "background-color:#353535;\n"
+ "color:#f2f3ed;\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}