$re = '/^.*(?=(?:color|background-color|background-image)\:.*?;).*/m';
$str = 'header p {
color:#f2f3ed;
background-color:#353535;
background-image: url(../images/dots.png);
}
header p {
background-image: url(../images/dots.png);
background-color:#353535;
color:#f2f3ed;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);