const regex = /^.*(?=(?:color|background-color|background-image)\:.*?;).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*(?=(?:color|background-color|background-image)\\:.*?;).*', 'gm')
const str = `header p {
color:#f2f3ed;
background-color:#353535;
background-image: url(../images/dots.png);
}
header p {
background-image: url(../images/dots.png);
background-color:#353535;
color:#f2f3ed;
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}