import re
regex = re.compile(r"^.*(?=(?:color|background-color|background-image)\:.*?;).*", flags=re.MULTILINE)
test_str = ("header p {\n"
"color:#f2f3ed;\n"
"background-color:#353535;\n"
"background-image: url(../images/dots.png);\n"
"}\n\n"
"header p {\n"
"background-image: url(../images/dots.png);\n"
"background-color:#353535;\n"
"color:#f2f3ed;\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")