using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w{2,})(\s|=)('|\"")(#|\s|\w.*?('|\""))";
string input = @"<a href= ""#"">asd</a>
<b href=""dfg"">asd</b>
<u href=""#"">asd</u>
<i href=""#"">asd</i>
<em href=""http://google.com"">asd</em>
<b>asd</b>
<u>asd</u>
<i>asd</i>
<em>asd</em>
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}