import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w{2,})(\\s|=)('|\\\")(#|\\s|\\w.*?('|\\\"))";
final String string = "<a href= \"#\">asd</a>\n\n"
+ "<b href=\"dfg\">asd</b>\n"
+ "<u href=\"#\">asd</u>\n"
+ "<i href=\"#\">asd</i>\n"
+ "<em href=\"http://google.com\">asd</em>\n\n"
+ "<b>asd</b>\n"
+ "<u>asd</u>\n"
+ "<i>asd</i>\n"
+ "<em>asd</em>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}