$re = '/(\w{2,})(\s|=)(\'|\")(#|\s|\w.*?(\'|\"))/i';
$str = '<a href= "#">asd</a>
<b href="dfg">asd</b>
<u href="#">asd</u>
<i href="#">asd</i>
<em href="http://google.com">asd</em>
<b>asd</b>
<u>asd</u>
<i>asd</i>
<em>asd</em>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);