const regex = /(\w{2,})(\s|=)('|\")(#|\s|\w.*?('|\"))/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w{2,})(\\s|=)(\'|\\")(#|\\s|\\w.*?(\'|\\"))', 'ig')
const str = `<a href= "#">asd</a>
<b href="dfg">asd</b>
<u href="#">asd</u>
<i href="#">asd</i>
<em href="http://google.com">asd</em>
<b>asd</b>
<u>asd</u>
<i>asd</i>
<em>asd</em>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}