package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\w{2,})(\s|=)('|\")(#|\s|\w.*?('|\"))`)
var str = `<a href= "#">asd</a>
<b href="dfg">asd</b>
<u href="#">asd</u>
<i href="#">asd</i>
<em href="http://google.com">asd</em>
<b>asd</b>
<u>asd</u>
<i>asd</i>
<em>asd</em>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}