import re
regex = re.compile(r"(\w{2,})(\s|=)('|\")(#|\s|\w.*?('|\"))", flags=re.IGNORECASE)
test_str = ("<a href= \"#\">asd</a>\n\n"
"<b href=\"dfg\">asd</b>\n"
"<u href=\"#\">asd</u>\n"
"<i href=\"#\">asd</i>\n"
"<em href=\"http://google.com\">asd</em>\n\n"
"<b>asd</b>\n"
"<u>asd</u>\n"
"<i>asd</i>\n"
"<em>asd</em>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")