# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/class="imgbrd lazy"\s+src=".*?"\s+data-original=/src=/gi;t' <<< "<img class=\"imgbrd lazy\" src=\"/something/iage.png\" data-original=\"/albums/uploadedpics/small1/017246.jpg\" border=\"0\">"