import re
regex = re.compile(r"class=\"imgbrd lazy\"\s+src=\".*?\"\s+data-original=", flags=re.IGNORECASE)
test_str = "<img class=\"imgbrd lazy\" src=\"/something/iage.png\" data-original=\"/albums/uploadedpics/small1/017246.jpg\" border=\"0\">"
subst = "src="
result = regex.sub(subst, test_str)
if result:
print(result)