# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^-]*-([^.]+).*/\1/gm;t' <<< "A17-R-Null-C-3.AT2G41240
A18-R-Null-C-3.AT2G41240
B19-R-Null-C-3.AT2G41240
B20-R-Null-C-3.AT2G41240
A21-R-Transgenic-C-3.AT2G41240
A22-R-Transgenic-C-3.AT2G41240"