import Foundation
let pattern = #"^[^-]*-([^.]+).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
A17-R-Null-C-3.AT2G41240
A18-R-Null-C-3.AT2G41240
B19-R-Null-C-3.AT2G41240
B20-R-Null-C-3.AT2G41240
A21-R-Transgenic-C-3.AT2G41240
A22-R-Transgenic-C-3.AT2G41240
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)