// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^-]*-([^.]+).*").unwrap();
let string = "A17-R-Null-C-3.AT2G41240
A18-R-Null-C-3.AT2G41240
B19-R-Null-C-3.AT2G41240
B20-R-Null-C-3.AT2G41240
A21-R-Transgenic-C-3.AT2G41240
A22-R-Transgenic-C-3.AT2G41240";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}