import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^-]*-([^.]+).*";
final String string = "A17-R-Null-C-3.AT2G41240\n"
+ "A18-R-Null-C-3.AT2G41240\n"
+ "B19-R-Null-C-3.AT2G41240\n"
+ "B20-R-Null-C-3.AT2G41240\n"
+ "A21-R-Transgenic-C-3.AT2G41240\n"
+ "A22-R-Transgenic-C-3.AT2G41240";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}