package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^-]*-([^.]+).*`)
var str = `A17-R-Null-C-3.AT2G41240
A18-R-Null-C-3.AT2G41240
B19-R-Null-C-3.AT2G41240
B20-R-Null-C-3.AT2G41240
A21-R-Transgenic-C-3.AT2G41240
A22-R-Transgenic-C-3.AT2G41240`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}