$re = '/^[^-]*-([^.]+).*/m';
$str = 'A17-R-Null-C-3.AT2G41240
A18-R-Null-C-3.AT2G41240
B19-R-Null-C-3.AT2G41240
B20-R-Null-C-3.AT2G41240
A21-R-Transgenic-C-3.AT2G41240
A22-R-Transgenic-C-3.AT2G41240';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;