const regex = /^[^-]*-([^.]+).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^-]*-([^.]+).*', 'gm')
const str = `A17-R-Null-C-3.AT2G41240
A18-R-Null-C-3.AT2G41240
B19-R-Null-C-3.AT2G41240
B20-R-Null-C-3.AT2G41240
A21-R-Transgenic-C-3.AT2G41240
A22-R-Transgenic-C-3.AT2G41240`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);