using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^.|.@.|.\.\w+$)(*SKIP)(*F)|.";
string substitution = @"*";
string input = @"xyzdsdasdas@xyss.com";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}