$re = '/(?:^.|.@.|.\.\w+$)(*SKIP)(*F)|./m';
$str = 'xyzdsdasdas@xyss.com';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;