const regex = /(?:^.|.@.|.\.\w+$)(*SKIP)(*F)|./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^.|.@.|.\\.\\w+$)(*SKIP)(*F)|.', 'gm')
const str = `xyzdsdasdas@xyss.com`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);