re = /(?:^.|.@.|.\.\w+$)(*SKIP)(*F)|./m
str = 'xyzdsdasdas@xyss.com'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result