package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^.|.@.|.\.\w+$)(*SKIP)(*F)|.`)
var str = `xyzdsdasdas@xyss.com`
var substitution = "*"
fmt.Println(re.ReplaceAllString(str, substitution))
}