#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(\d[\d\/ _-]*\d).*?([\w\._-]+@[\w\._-]+)"
Local $sString = "bla bla bla" & @CRLF & _
"" & @CRLF & _
"Willy Wuff" & @CRLF & _
"01234/5678910" & @CRLF & _
"willi.wuff@gmx.net" & @CRLF & _
"" & @CRLF & _
"weitergeleitete Mail:" & @CRLF & _
"bla bla blub" & @CRLF & _
"" & @CRLF & _
"Max Meier" & @CRLF & _
"0033/1 23 45 67 89" & @CRLF & _
"Email: meier@yahoo.fr" & @CRLF & _
"" & @CRLF & _
"die beiden Emailadressen und die beiden Telefonnummern ungeachtet ihrer Schreibweise herausgefiltert und z.B. in einer Datenbank abgelegt werden."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")