$re = '/(\d[\d\/ _-]*\d).*?([\w\._-]+@[\w\._-]+)/s';
$str = 'bla bla bla
Willy Wuff
01234/5678910
willi.wuff@gmx.net
weitergeleitete Mail:
bla bla blub
Max Meier
0033/1 23 45 67 89
Email: meier@yahoo.fr
die beiden Emailadressen und die beiden Telefonnummern ungeachtet ihrer Schreibweise herausgefiltert und z.B. in einer Datenbank abgelegt werden.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);