using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d[\d\/ _-]*\d).*?([\w\._-]+@[\w\._-]+)";
string input = @"bla bla bla
Willy Wuff
01234/5678910
willi.wuff@gmx.net
weitergeleitete Mail:
bla bla blub
Max Meier
0033/1 23 45 67 89
Email: meier@yahoo.fr
die beiden Emailadressen und die beiden Telefonnummern ungeachtet ihrer Schreibweise herausgefiltert und z.B. in einer Datenbank abgelegt werden.";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}