import Foundation
let pattern = #"(\d[\d\/ _-]*\d).*?([\w\._-]+@[\w\._-]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
bla bla bla
Willy Wuff
01234/5678910
willi.wuff@gmx.net
weitergeleitete Mail:
bla bla blub
Max Meier
0033/1 23 45 67 89
Email: meier@yahoo.fr
die beiden Emailadressen und die beiden Telefonnummern ungeachtet ihrer Schreibweise herausgefiltert und z.B. in einer Datenbank abgelegt werden.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)