// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)(\d[\d\/ _-]*\d).*?([\w\._-]+@[\w\._-]+)").unwrap();
let string = "bla bla bla
Willy Wuff
01234/5678910
willi.wuff@gmx.net
weitergeleitete Mail:
bla bla blub
Max Meier
0033/1 23 45 67 89
Email: meier@yahoo.fr
die beiden Emailadressen und die beiden Telefonnummern ungeachtet ihrer Schreibweise herausgefiltert und z.B. in einer Datenbank abgelegt werden.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}