# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d[\d\/ _-]*\d).*?([\w\._-]+@[\w\._-]+)"
test_str = ("bla bla bla\n\n"
"Willy Wuff\n"
"01234/5678910\n"
"willi.wuff@gmx.net\n\n"
"weitergeleitete Mail:\n"
"bla bla blub\n\n"
"Max Meier\n"
"0033/1 23 45 67 89\n"
"Email: meier@yahoo.fr\n\n"
"die beiden Emailadressen und die beiden Telefonnummern ungeachtet ihrer Schreibweise herausgefiltert und z.B. in einer Datenbank abgelegt werden.")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.