import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d[\\d\\/ _-]*\\d).*?([\\w\\._-]+@[\\w\\._-]+)";
final String string = "bla bla bla\n\n"
+ "Willy Wuff\n"
+ "01234/5678910\n"
+ "willi.wuff@gmx.net\n\n"
+ "weitergeleitete Mail:\n"
+ "bla bla blub\n\n"
+ "Max Meier\n"
+ "0033/1 23 45 67 89\n"
+ "Email: meier@yahoo.fr\n\n"
+ "die beiden Emailadressen und die beiden Telefonnummern ungeachtet ihrer Schreibweise herausgefiltert und z.B. in einer Datenbank abgelegt werden.";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}