#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ": (.*?) "
Local $sString = "Date: 03/03 - 14:10" & @CRLF & _
"" & @CRLF & _
"text" & @CRLF & _
"" & @CRLF & _
"And from" & @CRLF & _
"" & @CRLF & _
" Date/Time: 08/03/16 13:50" & @CRLF & _
"" & @CRLF & _
"Summary of Fault: "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")