import re
regex = re.compile(r": (.*?) ")
test_str = ("Date: 03/03 - 14:10\n\n"
"text\n\n"
"And from\n\n"
" Date/Time: 08/03/16 13:50\n\n"
"Summary of Fault: ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")